Правильная установка R в Debian 7

R — высокоуровневый язык программирования для статистической обработки данных. С помощью R, например, можно заниматься анализом временных рядов и предсказывать биржевые котировки.

Но у R в Debian есть один существенный недостаток — пакет очень старый. Ему вот-вот исполнится три года. И всё бы ничего, но R 2.15.1 несовместим с пакетом forecast, а R без forecast — как автомобиль без руля.

Как установить самую свежую версию R в Debian

Сначала добавим цифровую подпись стороннего репозитория (репозиторий сторонний по отношению к Debian, но родной для R):

apt-key adv --keyserver keys.gnupg.net --recv-key 381BA480

Ключ принадлежит Йоханесу Ранке, официальному чуваку из CRAN Debian archive.

Теперь добавим ссылку на репозиторий. В руководстве советуют добавлять прямо в /etc/apt/sources.list, но правильнее всё же в /etc/apt/sources.list.d/r.list:

deb http://<favorite-cran-mirror>/bin/linux/debian wheezy-cran3/

<favorite-cran-mirror> нужно заменить на адрес ближайшего (в географическом смысле) зеркала. Найти его можно в этом списке зеркал CRAN.

Далее всё как обычно:

  • обновляйте список пакетов;
  • устанавливайте R;
  • средства для сборки пакетов для R;
  • метапакет r-recommended с готовыми пакетами, рекомендуемыми R core team для установки по умолчанию.
apt-get update
apt-get install r-base
apt-get install r-base-dev
apt-get install r-recommended

Готово. Получили самую свежую версию R — 3.1.2 «Тыквенный шлем», которая к тому же будет обновляться вместе с дистрибутивом через apt-get update.

Ваша оценка: Нет Средняя оценка: 5 (2 votes)

Поправьте форматирование статьи, часть статьи в поле для кода

Ваша оценка: Нет Средняя оценка: 5 (2 votes)
pomodor

Спасибо!

Ваша оценка: Нет Средняя оценка: 3 (2 votes)

Спасибо, но debian wheezy-cran3/ устарел
На данный момент вроде работает
debian stretch-cran34/
(из-за дурацкого правила, что нельзя оставлять ссылки, ее могу дать полную ссылку под копи-паст)

Ваша оценка: Нет Средняя оценка: 1 (1 vote)

Все, поставил последнюю версию 3.4.3
Репозиторий: cran.rstudio.com/bin/linux/debian jessie-cran34/

Пытаюсь выполнить sudo apt-get update
получаю
GPG error: — cran.rstudio.com jessie-cran34/ Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY FCAE2A0E115C3D8A

Решение: sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys FCAE2A0E115C3D8A
потом опять sudo apt-get update
и далее по тексту статьи

Ваша оценка: Нет
Texnoline

дык ставь 9.2.1, 64 битный Debian — наше все молодежь, и Путин впереди! Ура Товарищи и Товарки:)

Ваша оценка: Нет
Отправить комментарий
КАПЧА
Вы человек? Подсказка: зарегистрируйтесь, чтобы этот вопрос больше никогда не возникал. Кстати, анонимные ссылки запрещены.
CAPTCHA на основе изображений
Enter the characters shown in the image.